Bug #1047

OpenNebulaNic.rb - can't get deploy_id & domid

Added by Oskar Johansson almost 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:12/31/2011
Priority:HighDue date:
Assignee:Jaime Melis% Done:

0%

Category:Core & SystemEstimated time:0.00 hour
Target version:Release 3.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.2

Description

I've found a bug that causes NicXen to not report domid (needed for VLAN support, it won't boot otherwise if VLAN is enabled.) The problem is a missing deploy_id. By simply copying working code from NicKVM to NicXen it starts working. I think this fix has to be inserted into the tree.

Tested with 3.1.90:

    def get_info(vm)
        if vm.deploy_id
            deploy_id = vm.deploy_id
        else
            deploy_id = vm['DEPLOY_ID']
        end

Associated revisions

Revision 75fabe78
Added by Jaime Melis almost 8 years ago

Bug #1047: can't get deploy_id & domid

History

#1 Updated by Ruben S. Montero almost 8 years ago

  • Status changed from New to Closed
  • Assignee set to Jaime Melis
  • Target version set to Release 3.2
  • Resolution set to fixed

#2 Updated by Ruben S. Montero almost 8 years ago

Hi Oskar,

Just wanted to thank foryour wonderful feedback with networking in Xen

Cheers

Ruben

Also available in: Atom PDF