Bug #108

VM MAC addresses not Random

Added by Marlon Nerling almost 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:05/25/2009
Priority:LowDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:Core & System
Target version:Release 1.4
Resolution:duplicate Pull request:
Affected Versions:

Description

One does not randomize the MAC addresses for the VMs, causing problems with a extern DHCP server.

Open nebula is responsible for the MAC addresses of the machine, we use a vn_template for this - Althought we do not use the NETWORK_ADDRESS (how could we?).

Says:
VM 613 and 614 are templates.
VM 613 has MAC=00:03:c0:a8:00:61
VM 614 has MAC=00:03:c0:a8:00:60
they will go up, change the own hostname and netname (to say 192-168-0-230), install some stuffs and wait.
613 goes down, one holds the disks back to the master.

VM 615 is a clone from the disks of 613, and now that 613 is DONE, one gives 615 the same MAC address (remember, it is a clone of the disks).
VM 615 goes up, changes the own hostname, start some services, register herself to our VM repository and waits.
Now our DHCP ( not really standard, since it relays on the hostname, too ) has a problem, cause one-613 does not released the IP!

The whole problem is of course not caused by open nebula, since to the DHCP should only the MAC address belong.

So.. I don't see it as a BUG, but as a new, nice to have FEATURE off open nebula, that it randomly generate the MACs!

Associated revisions

Revision abe78ed0
Added by Carlos Martín over 2 years ago

Merge pull request #108 from alvarosimon/fix_remote_user_auth

Bug #4748: Fix sunstone remote_auth login

History

#1 Updated by Marlon Nerling almost 10 years ago

Marlon Nerling wrote:

One does not randomize the MAC addresses for the VMs, causing problems with a extern DHCP server.

Open nebula is responsible for the MAC addresses of the machine, we use a vn_template for this - Althought we do not use the NETWORK_ADDRESS (how could we?).

Says:
VM 613 and 614 are templates.
VM 613 has MAC=00:03:c0:a8:00:61
VM 614 has MAC=00:03:c0:a8:00:60
they will go up, change the own hostname and netname (to say 192-168-0-230), install some stuffs and wait.
613 goes down, one holds the disks back to the master.

VM 615 is a clone from the disks of 613, and now that 613 is DONE, one gives 615 the same MAC address (remember, it is a clone of the disks) as 613.
VM 615 goes up, changes the own hostname, start some services, register herself to our VM repository and waits.
Now our DHCP ( not really standard, since it relays on the hostname, too ) has a problem, cause one-613 does not released the IP!

The whole problem is of course not caused by open nebula, since to the DHCP should only the MAC address belong.

So.. I don't see it as a BUG, but as a new, nice to have FEATURE off open nebula, that it randomly generate the MACs!

#2 Updated by Ruben S. Montero almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

I think that this kind of problems can be easily handled with the new Hook system. In this case you can easily create a script that adds the corresponding configuration when the VM is booted and removes when it is shutdown. I'll mark this as duplicate of #15

Also available in: Atom PDF