Bug #1923

Ozones should not use settings

Added by Javi Fontan almost 6 years ago. Updated almost 6 years ago.

Status:ClosedStart date:04/17/2013
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:-
Target version:Release 4.0
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.0

Description

Do not use settings from rack as it breaks the software with some rack versions:

(__DELEGATE__):2:in `settings': stack level too deep (SystemStackError)
        from (__DELEGATE__):2:in `send'
        from (__DELEGATE__):2:in `settings'
        from (__DELEGATE__):2:in `send'
        from (__DELEGATE__):2:in `settings'
        from (__DELEGATE__):2:in `send'
        from (__DELEGATE__):2:in `settings'
        from (__DELEGATE__):2:in `send'
        from (__DELEGATE__):2:in `settings'
         ... 2031 levels...
        from (__DELEGATE__):2:in `settings'
        from (__DELEGATE__):2:in `send'
        from (__DELEGATE__):2:in `settings'
        from /usr/lib/one/ozones/ozones-server.rb:100

Does not work in CentOS

Associated revisions

Revision ed0f40f5
Added by Javi Fontan almost 6 years ago

bug #1923: do not use rack settings in ozones server

Revision a46049d8
Added by Javi Fontan almost 6 years ago

bug #1923: do not use rack settings in ozones server

(cherry picked from commit ed0f40f582767749f5df1f383a30e9649a6dd60e)

History

#1 Updated by Javi Fontan almost 6 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Also available in: Atom PDF