Bug #36

not compiling under gcc 4.3.0

Added by fernando-arconada-conocimiento - about 11 years ago. Updated about 11 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:Tino Vázquez% Done:

0%

Category:Core & System
Target version:Release 1.2
Resolution:fixed Pull request:
Affected Versions:

Description

OpenNebula doesnt compile under gcc 4.3.0 cause it doesnt include all the libs that are subincluded in previous versions

Tested under Fedora Core 9

the problem its quite easy to solve: just add the required includes in that files:
include/Attribute.h
#include <algorithm>
src/host/HostShare.cc
#include <algorithm>
src/mad/Mad.cc
#include <string.h>
src/nebula/Log.cc
#include <stdlib.h>
src/rm/RequestManager.cc
#include <string.h>
src/pool/PoolSQL.cc
#include <algorithm>

Associated revisions

Revision 67bb5530
Added by Tino Vázquez about 11 years ago

Fix for ticket #36 - Not compiling under gcc 4.3.0

git-svn-id: http://svn.opennebula.org/one/trunk@110 3034c82b-c49b-4eb3-8279-a7acafdc01c0

History

#1 Updated by Ruben S. Montero about 11 years ago

  • Status changed from New to Assigned

Thanks for the patch!. This will make its way to the SVN repo.

#2 Updated by Tino Vázquez about 11 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Fixed in revision r110

Also available in: Atom PDF