Bug #97

Xen VM creation fails when the physical node has low memory

Added by Javi Fontan almost 10 years ago. Updated over 9 years ago.

Status:ClosedStart date:04/02/2009
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - Auth
Target version:Release 1.4
Resolution:worksforme Pull request:
Affected Versions:

Description

Somehow the available memory is not correct as I get this message when the physical host is tight on memory:

lines were cut to be displayed nicely

Thu Apr  2 19:50:22 2009 [VMM][I]: Command execution fail: 'cat > /images/one/var//44/images/deployment.0 && 
  sudo /usr/sbin/xm create /images/one/var//44/images/deployment.0 && 
  sudo /usr/sbin/xm sched-cred -d one-44 -w 26'
Thu Apr  2 19:50:22 2009 [VMM][I]: STDERR follows.
Thu Apr  2 19:50:22 2009 [VMM][I]: Error: I need 66560 KiB, but dom0_min_mem is 129024 and shrinking to 
  129024 KiB would leave only 50112 KiB free.

History

#1 Updated by Ruben S. Montero over 9 years ago

  • Target version set to Release 1.4

#2 Updated by Javi Fontan over 9 years ago

  • Resolution set to worksforme

We think that the problem is caused by a Xen misconfiguration and right now we can not reproduce it.

#3 Updated by Javi Fontan over 9 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF