Bug #1136

OpenNebulaNetwork.rb looking in the wrong path for brctl

Added by Jorge Espada about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:02/17/2012
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:CLI
Target version:-
Resolution:duplicate Pull request:
Affected Versions:OpenNebula 3.2

Description

I'm running opennebula 3.2.1 on debian squeeze, and when I try to create a vm on a node (also debian) fails, I found that the problem is in /var/lib/one/remotes/vnm/OpenNebulaNetwork.rb, the symbol reference :

:brctl=>"sudo /sbin/brctl"

is pointing to the wrong path, should be :
:brctl=>"sudo /usr/sbin/brctl"
Also a symblink can fix this too (/sbin/brctl -> /usr/sbin/brctl)

Some system Info:
OS: Debian (6)
Kernel: 2.6.32-5-amd64
bridge-utils version: 1.4-5
ruby: 1.8


Related issues

Duplicates Bug #1135: OpenNebulaNetwork.rb looking in the wrong path for brctl Closed 02/17/2012

History

#1 Updated by Jaime Melis about 8 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

duplicate of 1135

Also available in: Atom PDF