Bug #2046

Appflow error

Added by Cesare Rossi about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:05/14/2013
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:OneFlow
Target version:Release 4.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.8

Description

During deployment, when the ID of a certain type of role is greater than 9, there is the error "TypeError: can't convert Hash into String". This error can be saw either in Sunstone either via appflow list command. I attach complete response of the command.

appflow-list.error (164 KB) Cesare Rossi, 05/14/2013 03:54 PM

service_template.rtf (1.2 KB) Cesare Rossi, 05/27/2013 08:13 AM

History

#1 Updated by Carlos Martín about 7 years ago

  • Target version changed from Release 3.8.3 to Release 4.2

Hi,

I can't reproduce this. I've tried with a service with more than 10 roles, one of them with more than 10 nodes.
Can you provide a template that triggers this bug?

The ruby version may be relevant. Which one do you have installed?

Regards.

#2 Updated by Cesare Rossi about 7 years ago

Hi,

sorry for the late response, I had not seen your answer. The version of Ruby is 1.8.7.352-10.el6_4
I attach the service template.

Regards,

Cesare

#3 Updated by Cesare Rossi about 7 years ago

It depends from the maximum length of the body field of the document_pool table. To reproduce the error you can create a service template that, if instantiated, produces on database an XML greater than 65536 bytes.
To fix this error, it is enough modify the field type on database from text to mediumtext.

ALTER TABLE document_pool MODIFY COLUMN body mediumtext;

#4 Updated by Carlos Martín about 7 years ago

I'm glad you found it!
I tested it with OpenNebula 4.0 and sqlite... Anyway, this should be fixed in 4.0, see #1813.

In case you missed it, appflow 4.0 is almost ready: http://blog.opennebula.org/?p=4630

Cheers

#5 Updated by Daniel Molina about 7 years ago

  • Status changed from Pending to Closed
  • % Done changed from 0 to 100
  • Resolution set to fixed

Also available in: Atom PDF