Bug #2365

Password modificatio through Sunstone

Added by Rafael Manzo over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:10/08/2013
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Sunstone
Target version:Release 4.4
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 4.2

Description

If you try to change your password for one that contain a character % you'll get this error:

ArgumentError: invalid -encoding ({"action":{"perform":"passwd","params":{"password":""}}})

Which means that characters are not being scaped before get sent (are they getting encrypted?).

I have plenty of experience with rails. Since, Sunstone is a sinatra application I think I might be able to help with this, if you guys want of course :)

43.png (117 KB) Rafael Manzo, 10/10/2013 10:10 AM

History

#1 Updated by Daniel Molina over 6 years ago

Hi Rafael,

I cannot reproduce the error in the master branch of OpenNebula and using, Chrome. What browser are you using and I guess that you are running one-4.2.

BTW there was a similar bug in the login screen already solved.
http://dev.opennebula.org/issues/2078

#2 Updated by Rafael Manzo over 6 years ago

Hi Daniel,

I've been experiencing this issue with Firefox 24.0 on one-4.2. With Chromium 30.0.1599.66 (225456) it is the same. I've attached a screenshot.

Thanks!

#3 Updated by Daniel Molina over 6 years ago

We have just released OpenNebua 4.4beta, could you try this new version and check if the error is still there? Thank you

#4 Updated by Daniel Molina about 6 years ago

  • Status changed from Pending to Closed
  • % Done changed from 0 to 100
  • Resolution set to worksforme

Also available in: Atom PDF