Bug #2527

after VM delete-recreate onegate token is not valid

Added by Rolandas Naujikas over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Core & System
Target version:Release 4.6
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 4.4

Description

After VM delete-recreate onegate token is not accepted anymore.

+ curl -X PUT --header X-ONEGATE-TOKEN: *** http://***:***/vm/*** --data-binary @/tmp/tmp.***/curl.txt
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   103  100    14  100    89    149    947 --:--:-- --:--:-- --:--:--   978
Not authorized

The first instance works without problems.

History

#1 Updated by Carlos Martín over 6 years ago

  • Status changed from Pending to New
  • Priority changed from High to Normal
  • Target version set to Release 4.6
  • Start date deleted (12/02/2013)

Probably has to do with the fact that we just move the VM to pending, we don't re-parse the VM, and the context is not recreated.

A similar problem happens with CONTEXT/NETWORK=YES, if a NIC is attached the context doesn't include that new interface even if the VM is redeployed or recreated.

#2 Updated by Rolandas Naujikas over 6 years ago

If you will not fix for one-4.4, please at least document it as known problem.
Because of that I cannot recommend use this feature (onegate) in production.

#3 Updated by Carlos Martín over 6 years ago

Now it's included in the known issues page, thanks.
http://opennebula.org/documentation:rel4.4:known_issues

#4 Updated by Carlos Martín about 6 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

Hi,

I've been trying to reproduce it both in master and 4.4 branches, and delete + recreate does not have any effect on the authentication.
I'm closing this one for now, but feel free to reopen if you find any other clue.

Regards

Also available in: Atom PDF