Bug #2705

install_gems should install Nokogiri before other gems

Added by Javi Fontan about 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:02/04/2014
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Client API & Library
Target version:Release 4.6
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.4, OpenNebula 4.6

Description

Nokogiri version >= 1.6.0 is not compatible with ruby 1.8.7. install_gems detects ruby version and selects the appropriate version and is installed after the rest of the gems.

There is a new gem (aws-sdk) that depends on nokogiri. When this is not installed it tries to install the latest version and fails in ruby 1.8.7. A fix is installing nokogiri gem before.

Associated revisions

Revision 25e09550
Added by Javi Fontan about 6 years ago

bug #2705: install gems with specific version before normal gems

History

#1 Updated by Javi Fontan about 6 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Also available in: Atom PDF