Bug #318

oned clears the log on startup

Added by Szabolcs Székelyi over 10 years ago. Updated about 10 years ago.

Status:ClosedStart date:08/18/2010
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-
Resolution:wontfix Pull request:
Affected Versions:

Description

When oned starts, it truncates oned.log so all the information from the previous run is lost. This should not happen as log files should be append-only.

Associated revisions

Revision 37c3077f
Added by Jaime Melis about 10 years ago

option to backup oned.log (#318)

History

#1 Updated by Jaime Melis over 10 years ago

  • Priority changed from High to Normal
  • % Done changed from 0 to 100
  • Resolution set to wontfix

Hi, that is the intended behaviour for the oned.log file. If you want to back it up, consider applying a patch like the following (I haven't tested it):

http://pastebin.com/9KRe2f8G

Cheers

#2 Updated by Jaime Melis over 10 years ago

  • Status changed from New to Closed

#3 Updated by Jaime Melis about 10 years ago

In the end we have supplied a new option to the one command to backup oned.log:
one -b start

Also available in: Atom PDF