Bug #3949

Sunstone fails to examine a VM with a NIC that has no security groups at all

Added by Roy Keene about 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:08/25/2015
Priority:LowDue date:
Assignee:Daniel Molina% Done:

100%

Category:Sunstone
Target version:Release 4.14
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.12

Description

I get the JavaScript error:
TypeError: nic.SECURITY_GROUPS.split is not a function

When attempting to display a VM that has a NIC, but that NIC does not have any security groups at all.


Related issues

Duplicates Bug #3787: Interface stays in loading state when adding an NIC. Closed 05/01/2015

History

#1 Updated by Daniel Molina about 5 years ago

Hi Roy,

Could you send us the output of the onevm show VMID -x command for that VM?

#2 Updated by Daniel Molina about 5 years ago

  • Assignee set to Daniel Molina

#3 Updated by Daniel Molina about 5 years ago

  • Duplicates Bug #3787: Interface stays in loading state when adding an NIC. added

#4 Updated by Daniel Molina about 5 years ago

  • Target version set to Release 4.14

#5 Updated by Daniel Molina about 5 years ago

  • Status changed from Pending to New

#6 Updated by Daniel Molina about 5 years ago

  • Status changed from New to Closed

Fixed in master, thank you for the feedback

#7 Updated by Daniel Molina about 5 years ago

  • % Done changed from 0 to 100
  • Resolution set to fixed

Fixed in master, thank you for the feedback

Also available in: Atom PDF