Bug #3972

Updates for select fields are case sensitive

Added by Martijn Kint about 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:09/08/2015
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Sunstone
Target version:Release 4.14
Resolution:fixed Pull request:
Affected Versions:Development, OpenNebula 4.12

Description

Hi,

I'm not totally sure if this belongs here or should be marked as a bug for the appmarket. Please let me know if I need to post it @ https://github.com/OpenNebula/addon-appmarket

When you import an applicance from the Appmarket a template and image get created. With the following json strings in the template some of the features (ACPI and LOCALTIME) are missing/not present.

I have tried the following two json versions in the appliance template:

Not working 1:

{
    "CONTEXT": {
        "NETWORK": "YES",
        "SSH_PUBLIC_KEY": "$USER[SSH_PUBLIC_KEY]" 
    },
    "CPU": "1",
    "VCPU": "1",
    "GRAPHICS": {
        "LISTEN": "0.0.0.0",
        "TYPE": "vnc" 
    },
    "MEMORY": "1024",
    "OS": {
        "ARCH": "x86_64",
        "ACPI": "YES",
        "LOCALTIME": "NO" 
    },
    "LOGO": "images/logos/ubuntu.png" 
}

Not working 2:

{
    "CONTEXT": {
        "NETWORK": "YES",
        "SSH_PUBLIC_KEY": "$USER[SSH_PUBLIC_KEY]" 
    },
    "CPU": "1",
    "VCPU": "1",
    "GRAPHICS": {
        "LISTEN": "0.0.0.0",
        "TYPE": "vnc" 
    },
    "FEATURES": {
        "ACPI": "YES",
        "LOCALTIME": "NO" 
    },
    "MEMORY": "1024",
    "OS": {
        "ARCH": "x86_64" 
    },
    "LOGO": "images/logos/ubuntu.png" 
}

The attached screenshot shows that both ACPI and LOCALTIME are not set from the json settings as provided in the examples above.

Screen Shot 2015-09-08 at 13.42.04.png - missing settings (43.6 KB) Martijn Kint, 09/08/2015 11:46 AM

Associated revisions

Revision 7074b476
Added by Carlos Martín about 5 years ago

Bug #3972: Make WizarFields.fill() case insensitive

History

#1 Updated by Martijn Kint about 5 years ago

BTW it seems to bee a Sunstone only bug, onetemplate show <template_id> shows the correct output with the second JSON example.

NAME           : Ubuntu 14.04 JSON test
USER           : oneadmin            
GROUP          : oneadmin            
REGISTER TIME  : 09/08 13:53:20      

PERMISSIONS                                                                     
OWNER          : um-                 
GROUP          : ---                 
OTHER          : ---                 

TEMPLATE CONTENTS                                                               
CONTEXT=[
  NETWORK="YES",
  SSH_PUBLIC_KEY="$USER[SSH_PUBLIC_KEY]" ]
CPU="1" 
DISK=[
  IMAGE="Ubuntu 14.04 JSON test",
  IMAGE_UNAME="oneadmin" ]
FEATURES=[
  ACPI="YES",
  LOCALTIME="NO" ]
FROM_APP="55a3ac71d4219313b3000005" 
FROM_APP_NAME="Ubuntu 14.04 Server - KVM" 
GRAPHICS=[
  LISTEN="0.0.0.0",
  TYPE="vnc" ]
LOGO="images/logos/ubuntu.png" 
MEMORY="1024" 
OS=[
  ARCH="x86_64" ]
VCPU="1" 

#2 Updated by Carlos Martín about 5 years ago

  • Subject changed from Appmarket json features not exposed in template view to Updates for select fields are case sensitive
  • Category set to Sunstone
  • Status changed from Pending to New
  • Assignee set to Carlos Martín
  • Target version set to Release 4.14
  • Affected Versions Development added

Hi,

I've done a quick test and the problem is that the values are case sensitive, sunstone only works with "yes" in lowercase.
This will be fixed in 4.14.

Regards

#3 Updated by Carlos Martín about 5 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF