Bug #4000

History etime is not set on shutdown timeout

Added by Carlos Martín almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:09/24/2015
Priority:HighDue date:
Assignee:Carlos Martín% Done:

0%

Category:Core & System
Target version:Release 4.14.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.12

Description

Bug reported in this thread:
https://forum.opennebula.org/t/oneacct-shows-vms-that-does-not-exist/1233

I could reproduce the problem.
I had created a Windows 7 VM.
Then I wanted the VM to shutdown (not hard).
The VM at this point had no ACPI functionality and OpenNebula said "STATUS: SHUTDOWN".
Then I performed a SHUTDOWN HARD. OpenNebula said that this action was not allowed due to wrong status. Than I remowed the VM and the VM disappeared from onevm list.

Associated revisions

Revision ee44b970
Added by Carlos Martín almost 5 years ago

Bug #4000: Fix history etime with onedb

Revision f3ba7ee1
Added by Carlos Martín almost 5 years ago

Bug #4000: Fix history etime with onedb

(cherry picked from commit ee44b97013eee45e0a1ace90520832f93292e73e)

Revision 805c3a28
Added by Carlos Martín almost 5 years ago

Bug #4000: Fix history etime with onedb

Revision 9b4f9f6c
Added by Carlos Martín almost 5 years ago

Bug #4000: Remove comments

Revision 94a9ca2d
Added by Carlos Martín almost 5 years ago

Bug #4000: Remove comments

(cherry picked from commit 9b4f9f6c4ff4f8068ab89d6501ddcbf85d0c8ba7)

History

#1 Updated by Carlos Martín almost 5 years ago

  • Status changed from Pending to New

I can reproduce it in 4.12.1, but not in 4.14.0.

It leaves the etime unset if a onevm delete is executed while the VM is in state shutdown_undeploy.

Even if the bug is not present in 4.14, we should update fsck to look for this inconsistency.

#2 Updated by Carlos Martín almost 5 years ago

  • Target version set to Release 4.14.2

#3 Updated by Carlos Martín almost 5 years ago

  • Assignee set to Carlos Martín

#4 Updated by Carlos Martín almost 5 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF