Bug #4025

sunstone: VM actions greyed out in VM details

Added by Laurent Grawet almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:10/05/2015
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Sunstone
Target version:Release 4.14.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.14

Description

Hi,

When entering VM details, actions like shutdown, reboot... remain grayed out until we click on the refresh button.

Regards,

Laurent


Related issues

Duplicated by Bug #4163: Extra "refresh" needed in sunstone before available actio... Closed 11/17/2015

Associated revisions

Revision 21e616be
Added by Carlos Martín almost 5 years ago

Bug #4025: Prevent race condition in call to disableAllStateActions

Revision d1370c9d
Added by Carlos Martín almost 5 years ago

Bug #4025: Prevent race condition in call to disableAllStateActions

(cherry picked from commit 21e616be59f2ec557bf9828dd446b0197a044100)

History

#1 Updated by Carlos Martín almost 5 years ago

  • Target version set to Release 4.14.2

Hi,

I can't reproduce this one. I've tried jumping between VMs in different states, opening a VM from the host's VMs list...
Does is happen all the time for you, or do you have a set of steps that trigger it?

#2 Updated by Laurent Grawet almost 5 years ago

I tried with Chrome and Iceweasel under Linux. Another user is using Chrome under Windows 2012R2, and another one is using Safari under Mac OS X. They all face the same problem. It's 100% reproducible. No special steps, just click on VM in VM list or from host's VMs list. We are using lighttpd server.

#3 Updated by Carlos Martín almost 5 years ago

  • Status changed from Pending to Closed
  • Assignee set to Carlos Martín
  • Resolution set to fixed

I found a race condition in the code.
The fix will be included in the next maintenance release.

Thanks for reporting it!

#4 Updated by Carlos Martín almost 5 years ago

  • Duplicated by Bug #4163: Extra "refresh" needed in sunstone before available actions are updated added

Also available in: Atom PDF