Bug #4241

normal users see spinning log after upgrade to 4.14.2

Added by Valerio Schiavoni almost 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:12/14/2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:invalid Pull request:
Affected Versions:OpenNebula 4.14

Description

After upgrading from 4.10 to 4.14.02, normal users (not oneadmin) see a spinning logo after the login form.
I've already tried removing browse cache, using incognito/private modes from Safari and Chrome.

These are the sunstone logs for the incognito session:


Mon Dec 14 10:33:27 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:27] "POST /login HTTP/1.1" 204 - 0.1864
Mon Dec 14 10:33:27 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:27] "GET / HTTP/1.1" 200 - 0.0214
Mon Dec 14 10:33:27 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:27] "GET /locale/languages/en_US.js?v=4.14.2 HTTP/1.1" 200 - 0.0049
Mon Dec 14 10:33:27 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:27] "GET /css/app.min.css?v=4.14.2 HTTP/1.1" 200 - 0.0106
Mon Dec 14 10:33:28 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:28] "GET /dist/main.js?v=4.14.2 HTTP/1.1" 200 - 0.3271
Mon Dec 14 10:33:28 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:28] "GET /bower_components/fontawesome/fonts/fontawesome-webfont.woff?v=4.3.0 HTTP/1.1" 200 - 0.0060
Mon Dec 14 10:33:28 2015 [I]: 130.125.11.191 - - [14/Dec/2015 10:33:28] "GET /css/opensans/opensans.woff HTTP/1.1" 200 - 0.0060

Attached a screencast of what the users see.

ON_4_14_sunstone_login.mov - screencast of the user experience, spinning logo. (4.49 MB) Valerio Schiavoni, 12/14/2015 09:37 AM

stunstone_bug_log.txt Magnifier (2.13 KB) Shreyas Parikh, 04/19/2016 02:32 PM

Updated_debian8_packages.txt Magnifier (2.13 KB) Shreyas Parikh, 04/19/2016 02:37 PM

History

#1 Updated by Valerio Schiavoni almost 2 years ago

There was a problem during the update, and the user.yaml were not conform with the newer format.

#2 Updated by Daniel Molina almost 2 years ago

  • Status changed from Pending to Closed
  • Resolution set to invalid

#3 Updated by Shreyas Parikh over 1 year ago

I am facing same issue after upgrade sunstone from 4.12 to 4.14.
Here i attached log file

#4 Updated by Shreyas Parikh over 1 year ago

attached updated packages list too

Also available in: Atom PDF