Bug #4357

Making any user config change resets VNC_WSS to 'no' PATCH INCLUDED

Added by Bill Cole over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:02/25/2016
Priority:NormalDue date:
Assignee:Daniel Molina% Done:

100%

Category:SunstoneEstimated time:0.10 hour
Target version:Release 5.0
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.12, OpenNebula 4.14

Description

Revision 4c6e4986 removed the VNC encryption checkbox from the config tab UI, but the code using it to set vnc_wss remained. As a result, switching to a different Sunstone view flipped off encryption so VNC seemed to not work in the newly-chosen view.

The included patch is very simple: removes 6 lines (one empty) from one file in the 4.12 branch. This part of Sunstone has apparently been entirely refactored for 4.14, so it is likely not relevant to the trunk.

config-tab.js.patch Magnifier - patch for src/sunstone/public/js/plugins/config-tab.js (1.13 KB) Bill Cole, 02/25/2016 02:39 AM

Associated revisions

Revision 5fb6f638
Added by Daniel Molina over 4 years ago

Bug #4357: Do not change VNC_WSS after USER config update
Contributed by Bill Cole, http://dev.opennebula.org/issues/4357

Revision 2834b2a8
Added by Daniel Molina over 4 years ago

Bug #4357: Do not retrieve VNC_WSS from the USER template

Revision d24655f8
Added by Daniel Molina over 4 years ago

Bug #4357: Do not retrieve VNC_WSS from the USER template
(cherry picked from commit 2834b2a8f0f135d890dc44d587e2e36af3385293)

Revision 7771ed83
Added by Daniel Molina over 4 years ago

Bug #4357: Do not retrieve VNC_WSS from the USER template

History

#1 Updated by Daniel Molina over 4 years ago

  • Status changed from Pending to New
  • Assignee set to Daniel Molina
  • Target version set to Release 5.0
  • Affected Versions OpenNebula 4.14 added

Hi Bill,

Thank you for the patch, as you mentioned it doesn't apply for one-4.14 since that code was removed/refactored.
That code should not modify the VNC wss configuration, but the problem is this other line in sunstone-server.rb that should also be removed from both one-4.12 and one-4.14, since the VNC wss configuration is retrieved from the server config file

https://github.com/OpenNebula/one/blob/release-4.14.2/src/sunstone/sunstone-server.rb#L452

#2 Updated by Daniel Molina over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Resolution set to fixed

Fixed, thank you

Also available in: Atom PDF