Bug #4531

OpenNebula 5.0 beta 3 (4.90.10) fails to upgrade on Ubuntu

Added by Stefan Kooman almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:06/08/2016
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Packaging
Target version:Release 5.0
Resolution:fixed Pull request:
Affected Versions:Development

Description

4.90.0.0-1 installed, try to upgrade to 4.90.10-1:

apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
language-selector-common libopennebula-java libopennebula-java-doc libxml2 opennebula opennebula-common
opennebula-flow opennebula-gate opennebula-sunstone opennebula-tools ruby-opennebula
11 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 15.0 MB of archives.
After this operation, 982 kB disk space will be freed.
Do you want to continue? [Y/n]
Get:1 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 language-selector-common all 0.165.3 [214 kB]
Get:2 http://nl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libxml2 amd64 2.9.3+dfsg1-1ubuntu0.1 [696 kB]
Get:3 http://obit.bit.nl/ubuntu/xenial/opennebula ./ libopennebula-java 4.90.10-1 [64.5 kB]
Get:4 http://obit.bit.nl/ubuntu/xenial/opennebula ./ libopennebula-java-doc 4.90.10-1 [77.2 kB]
Get:5 http://obit.bit.nl/ubuntu/xenial/opennebula ./ opennebula-flow 4.90.10-1 [27.7 kB]
Get:6 http://obit.bit.nl/ubuntu/xenial/opennebula ./ opennebula-sunstone 4.90.10-1 [6,856 kB]
Get:7 http://obit.bit.nl/ubuntu/xenial/opennebula ./ opennebula 4.90.10-1 [6,770 kB]
Get:8 http://obit.bit.nl/ubuntu/xenial/opennebula ./ opennebula-tools 4.90.10-1 [101 kB]
Get:9 http://obit.bit.nl/ubuntu/xenial/opennebula ./ opennebula-gate 4.90.10-1 [10.5 kB]
Get:10 http://obit.bit.nl/ubuntu/xenial/opennebula ./ ruby-opennebula 4.90.10-1 [206 kB]
Get:11 http://obit.bit.nl/ubuntu/xenial/opennebula ./ opennebula-common 4.90.10-1 [11.5 kB]
Fetched 15.0 MB in 0s (38.5 MB/s)
(Reading database ... 48537 files and directories currently installed.)
Preparing to unpack .../language-selector-common_0.165.3_all.deb ...
Unpacking language-selector-common (0.165.3) over (0.165.2) ...
Preparing to unpack .../libxml2_2.9.3+dfsg1-1ubuntu0.1_amd64.deb ...
Unpacking libxml2:amd64 (2.9.3+dfsg1-1ubuntu0.1) over (2.9.3+dfsg1-1) ...
Preparing to unpack .../libopennebula-java_4.90.10-1_all.deb ...
Unpacking libopennebula-java (4.90.10-1) over (4.90.0-1) ...
Preparing to unpack .../libopennebula-java-doc_4.90.10-1_all.deb ...
Unpacking libopennebula-java-doc (4.90.10-1) over (4.90.0-1) ...
Preparing to unpack .../opennebula-flow_4.90.10-1_all.deb ...
Unpacking opennebula-flow (4.90.10-1) over (4.90.0-1) ...
Preparing to unpack .../opennebula-sunstone_4.90.10-1_all.deb ...
Unpacking opennebula-sunstone (4.90.10-1) over (4.90.0-1) ...
Preparing to unpack .../opennebula_4.90.10-1_amd64.deb ...
Unpacking opennebula (4.90.10-1) over (4.90.0-1) ...
dpkg: error processing archive /var/cache/apt/archives/opennebula_4.90.10-1_amd64.deb (--unpack):
trying to overwrite '/etc/one/auth/x509_auth.conf', which is also in package ruby-opennebula 4.90.0-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../opennebula-tools_4.90.10-1_all.deb ...
Unpacking opennebula-tools (4.90.10-1) over (4.90.0-1) ...
dpkg: regarding .../opennebula-gate_4.90.10-1_all.deb containing opennebula-gate:
opennebula-gate conflicts with opennebula (<< 4.90.10-1)
opennebula (version 4.90.0-1) is present and installed.

dpkg: error processing archive /var/cache/apt/archives/opennebula-gate_4.90.10-1_all.deb (--unpack):
conflicting packages - not installing opennebula-gate
Preparing to unpack .../ruby-opennebula_4.90.10-1_all.deb ...
Unpacking ruby-opennebula (4.90.10-1) over (4.90.0-1) ...
dpkg: error processing archive /var/cache/apt/archives/ruby-opennebula_4.90.10-1_all.deb (--unpack):
trying to overwrite '/usr/lib/one/ruby/cloud/CloudAuth/OneGateCloudAuth.rb', which is also in package opennebula-gate 4.90.0-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../opennebula-common_4.90.10-1_all.deb ...
Unpacking opennebula-common (4.90.10-1) over (4.90.0-1) ...
Processing triggers for dbus (1.10.6-1ubuntu3) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
/var/cache/apt/archives/opennebula_4.90.10-1_amd64.deb
/var/cache/apt/archives/opennebula-gate_4.90.10-1_all.deb
/var/cache/apt/archives/ruby-opennebula_4.90.10-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

History

#1 Updated by Javi Fontan almost 5 years ago

  • Category set to Packaging
  • Status changed from Pending to Closed
  • Assignee set to Javi Fontan
  • Target version set to Release 5.0
  • Resolution set to fixed

The package generation was changed so apt knows about these changes. It should be fixed for 5.0.0. Tested with Debian 8 and Ubuntu 14 from 4.14 to nightly build (5.0.0) and Ubuntu 16 from 4.90.0.

It should be upgraded using repository. The command dpkg -i <packages> is not able to resolve the conflicts.

Also available in: Atom PDF