Bug #4591

Strange behavior with capacity modification and unit switching

Added by EOLE Team over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:06/22/2016
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Sunstone
Target version:Release 5.0.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0

Description

Hello,

I tried the several option of capacity limitation in VM template, I have a tiny cosmetic problem with the list:

  • I set Memory to 1GB
  • I set memory modification to list
  • I set value to 0.5,1,2

When instantiating a VM template:

  • default memory is 1GB
  • I switch unit to MB, it displays the value 1024
  • I select 512 MB
  • I switch unit to GB, it displays 0.5
  • I select 2GB
  • I switch unit to MB, it displays 512

It looks like the previous value in a unit is reused instead of converting the current value to the new unit.

Regards.

bug-4591.mp4 (950 KB) Carlos Martín, 06/22/2016 01:08 PM

capacity-bug.webm (349 KB) EOLE Team, 06/22/2016 01:42 PM


Related issues

Duplicated by Bug #4738: Memory selection does not work when using GB units in Fir... Closed 08/23/2016

Associated revisions

Revision ae17550a
Added by Carlos Martín over 3 years ago

Bug #4591: Fix GB inputs in firefox

Revision 0e7bf161
Added by Carlos Martín over 3 years ago

Bug #4591: Fix GB inputs in firefox

(cherry picked from commit e349c718782dc7c1120882678b4610d6e938f54d)

History

#1 Updated by Carlos Martín over 3 years ago

Hi,

I've tried to reproduce it, with no luck (see attached video).
Does it happen consistently for you?

#2 Updated by EOLE Team over 3 years ago

Yes, on firefox 48.0b1 and 45.2-ESR.

Screencast is with 48.0b1 in fr_FR, the same problem in en_US.

No error in the JS console during manipulation.

Regards.

#3 Updated by Carlos Martín over 3 years ago

  • Status changed from Pending to Closed
  • Assignee set to Carlos Martín
  • Target version set to Release 5.0.2
  • Resolution set to fixed

Fixed, thank you

#4 Updated by Carlos Martín over 3 years ago

  • Duplicated by Bug #4738: Memory selection does not work when using GB units in Firefox added

Also available in: Atom PDF