Bug #4674

User view is broken after 5.0.2 upgrade

Added by EOLE Team over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:07/22/2016
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Sunstone
Target version:Release 5.0.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0

Description

Hello,

I just upgrade our lab to 5.0.2 and I have an issue with the user view, here is what I have in my JS log

Error: No tabs/oneflow-dashboard-tab main.js:184:19
callDep()
main.js:184
req()
main.js:345
makeRequire/<()
main.js:159
_addActions/<()
main.js:45103
.each()
main.js:798
_addActions()
main.js:45101
_addMainTabs()
main.js:45065
<anonymous>
main.js:128943
jQuery.Callbacks/fire()
main.js:3620
jQuery.Callbacks/self.add()
main.js:3679
jQuery.fn.ready()
main.js:3929
<anonymous>
main.js:128941
main()
main.js:314
callDep()
main.js:180
main()
main.js:305
req/<()
main.js:388

Only the user.yaml references a oneflow-dashboard-tab (source:src/sunstone/etc/sunstone-views/user.yaml@2c26ec43#L759) which is not even referenced in enabled_tabs (source:src/sunstone/etc/sunstone-views/user.yaml@2c26ec43#L3).

Removing the *oneflow-dashboard-tab and its sub element make it working.

Regards.

Associated revisions

Revision 4f0d75d1
Added by Carlos Martín over 4 years ago

Bug #4674: Fix user view, update other view contents to match the original admin.yaml better

Revision 03add2e6
Added by Carlos Martín over 4 years ago

Bug #4674: Fix user view, update other view contents to match the original admin.yaml better

(cherry picked from commit 4f0d75d1ea102a539500160a5c1a615bff9df135)

History

#1 Updated by EOLE Team over 4 years ago

For the record, I'm using Firefox.

#2 Updated by Carlos Martín over 4 years ago

  • Status changed from Pending to Closed
  • Assignee set to Carlos Martín
  • Resolution set to fixed

Fixed, thanks a lot!

#3 Updated by Carlos Martín over 4 years ago

  • Target version set to Release 5.0.2

#4 Updated by OpenNebula Systems Support Team over 4 years ago

Fixed in a new version of 5.0.2 packages, please update

Also available in: Atom PDF