Bug #4749

Unauthorized NIC add

Added by Anton Zubkov about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:08/26/2016
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:vCenter
Target version:-
Resolution: Pull request:
Affected Versions:OpenNebula 5.0, OpenNebula 5.2

Description

Every SHUTDOWN and then START VM - add new NIC to VM in vCenter with same MAC.

History

#1 Updated by Carlos Martín about 3 years ago

  • Category set to vCenter

#2 Updated by Miguel Ángel Álvarez Cabrerizo about 3 years ago

Hi Anton,
thanks for your feedback, I'm trying to reproduce this bug.

What ESX version are you running?

When the VM is running, what OpenNebula's action do you use to shutdown the running VM (stop, pause, poweroff, poweroff --hard, undeploy, undeploy --hard)?. Would it be possible to send me the oned.log and the VM log when this problem happens?

Thanks in advance

#3 Updated by Miguel Ángel Álvarez Cabrerizo about 3 years ago

  • Status changed from Pending to Closed
  • Affected Versions OpenNebula 5.2 added

Though we could not reproduce in testing, the only possible way that a NIC was duplicated would be created by the following condition:

if nic.elements["MAC"].text dv.macAddress and nic.elements["BRIDGE"].text dv.deviceInfo.summary

It seems that dv.deviceInfo.summary would not contain the bridge name in certain cases that cannot be determined so the condition is set to:

if nic.elements["MAC"].text == dv.macAddress

which fixes the problem for an affected user. A PR has been created.

Also available in: Atom PDF