Bug #4853

DataTables type error after a cluster update

Added by Carlos Martín about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:10/06/2016
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Sunstone
Target version:Release 5.2
Resolution:fixed Pull request:
Affected Versions:Development

Description

To reproduce:

2 vnets in cluster 0.
Go to cluster 0, remove both vnets.
Go back to the list of clusters, the table will not be rendered.

Associated revisions

Revision 43b8c108
Added by Carlos Martín about 4 years ago

B #4853: Execute all cache callbacks even when one of them fails

History

#1 Updated by Carlos Martín about 4 years ago

  • Subject changed from Vnet table, cluster column error to DataTables type error after a cluster update
  • Status changed from New to Closed
  • Assignee set to Carlos Martín
  • Resolution set to fixed

After the commit to call all of the cache callbacks even if one them fails, the reason for the problem seems to be:

- Start on the individual Cluster view
- Update the cluster adding/removing elements
- When sunstone returns to the individual views, a few errors are thrown:
TypeError: Cannot set property '_DT_CellIndex' of undefined

I'm going to close the ticket even if those errors are still there. Probably the problem is trying to refresh the dialog datatables that are destroyed at that point, or something similar. It doesn't seem to affect the functionality.

Also available in: Atom PDF