nokogiri version 184.108.40.206 incompatible with ruby 2.0.0 centos7
|Category:||Core & System|
|Affected Versions:||OpenNebula 5.2|
When running the install_gems script on CentOS7, nokogiri causes the script to fail because it is not compatible with the default ruby version on centos7 (see output below).
I've attached a possible patch to force the version to lower than 1.7.0 if ruby is < 2.1.0.
[root@onemgmt ~]# /usr/share/one/install_gems lsb_release command not found. If you are using a RedHat based distribution install redhat-lsb Select your distribution or press enter to continue without installing dependencies. 0. Ubuntu/Debian 1. CentOS/RedHat/Scientific 1 Distribution "redhat" detected. About to install these dependencies: * gcc-c++ * ruby-devel * make Press enter to continue... yum install gcc-c++ ruby-devel make Failed to set locale, defaulting to C Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centos.mirror.triple-it.nl * epel: epel.check-update.co.uk * extras: mirrors.noction.com * updates: mirror.prolocation.net Package gcc-c++-4.8.5-11.el7.x86_64 already installed and latest version Package ruby-devel-220.127.116.118-29.el7.x86_64 already installed and latest version Package 1:make-3.82-23.el7.x86_64 already installed and latest version Nothing to do Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root users on this machine. Fetching gem metadata from https://rubygems.org/............ Fetching version metadata from https://rubygems.org/.. Fetching dependency metadata from https://rubygems.org/. Resolving dependencies... nokogiri-18.104.22.168 requires ruby version >= 2.1.0, which is incompatible with the current version, ruby 2.0.0p648 Error installing gems [root@onemgmt ~]#