Bug #5291

VM Instances error in order by ID

Added by Kristian Feldsam about 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:07/27/2017
Priority:HighDue date:
Assignee:Abel Coronado% Done:

100%

Category:Sunstone
Target version:Release 5.4.1
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.4

Description

After upgrade to 5.4 from 5.2 I experience error in ordering VMs by ID, so I can't see machines in order from newest to oldest.

Looks like there is problem with vm ID > 9999, so everything what have ID 10000 and up is at bottom :(

asc.png (66.1 KB) Abel Coronado, 07/28/2017 09:47 AM

desc.png (67 KB) Abel Coronado, 07/28/2017 09:47 AM

nebula_broken_ordering.png (24.7 KB) Perry Manuk, 08/17/2017 04:09 PM

Associated revisions

Revision 427322eb
Added by Abel Coronado about 3 years ago

B #5291 Solved bug VM Instances error in order by ID (#422)

Revision 6a3c5b3f
Added by Abel Coronado about 3 years ago

B #5291 Solved bug VM Instances error in order by ID (#422)

(cherry picked from commit 427322ebb57305a919e9183acea3108091b5242d)

Revision 19396e38
Added by Abel Coronado almost 3 years ago

B #5291 Solved order VM bug in cloud view (#428)

Revision 6198e03e
Added by Abel Coronado almost 3 years ago

B #5291 Solved order VM bug in cloud view (#428)

(cherry picked from commit 19396e386457ed3e6e761ee0ea7a94d833946ba7)

Revision cba1e26c
Added by Abel Coronado almost 3 years ago

B #5291 Solved bugs number order (#430)

  • B #5291 Solved bug with integer dates in showback order
  • B #5291 Solved bug in all datatable when field is number

Revision 02260cb4
Added by Abel Coronado almost 3 years ago

B #5291 Solved bugs number order (#430)

  • B #5291 Solved bug with integer dates in showback order
  • B #5291 Solved bug in all datatable when field is number

(cherry picked from commit cba1e26ce96403d5ce22c3e7465ffb981b5f518c)

History

#1 Updated by Kristian Feldsam about 3 years ago

Problem is in every view - cloud, user, admin.... also if no order is specified, so looks like this is not sunstone error, but VMs are in bad order when returning from rpc api

#2 Updated by Abel Coronado about 3 years ago

  • Assignee set to Abel Coronado

#3 Updated by Abel Coronado about 3 years ago

Solved.

Thanks for the report.

Regards.

#4 Updated by Abel Coronado about 3 years ago

  • % Done changed from 0 to 100

#5 Updated by Kristian Feldsam about 3 years ago

Hello, thank you. Any path or git commit ref? I like to try it. Thanks

#7 Updated by Kristian Feldsam about 3 years ago

Hello, I tried it, it is partially fixed. Cloud view still doesn't work.

#8 Updated by Abel Coronado about 3 years ago

I can't reproduce the problem.

Try with this in /src/sunstone/public/app/tabs/provision-tab/vms/list.js (line 144):

"aoColumnDefs": [
    { "bVisible": false, "aTargets": ["all"]},
    { "sType": "num", "aTargets": [0]}
],

#9 Updated by Kristian Feldsam about 3 years ago

yes, it is working in cloud view now.

#10 Updated by Kristian Feldsam about 3 years ago

hello, there are more places where order is bad. For ex, today I see it in showback table, when I order by VM hours, 9h is more that 728h. Also wehn I order by ID or Cost -- all numeric columns. It looks like all tables are affected. Also small table in showback showing Months/Prices

#11 Updated by Perry Manuk almost 3 years ago

I am also having the same issue

#12 Updated by Abel Coronado almost 3 years ago

Solved bug in showback.

Regards.

#13 Updated by Abel Coronado almost 3 years ago

Kristian is right. This bug affect all tables in Sunstone when a field is a number.

Bug fixed.

Thanks for the report.

#14 Updated by Tino Vázquez almost 3 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Also available in: Atom PDF