Bug #5336

Can't attach disk to VM

Added by Edouard Bourguignon about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:08/30/2017
Priority:NormalDue date:
Assignee:Abel Coronado% Done:

100%

Category:Sunstone
Target version:Release 5.4.1
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.4

Description

Hello,

Since upgrade to 5.4 when can't attach disk anymore on running VMs.

This is 100% reproductible we have the same bug on all our opennebula.

steps to reproduce:

- Create 1 vm (we are using centos 7 kvm template from marketplace, not relevant for the bug)
- While the VM is running, go to storage tab, click on attach disk
- Choose volatile, type 1 GB for the size (or any size), and just change Filesystem format to qcow2
- Click on attach

OpenNebula will then create an image disk but in raw format.
The XML definition (disk.X.attach) for this attachment is set with this image but with qcow2 specified, so when ONE push it to libvirtd, it fails with the following error:
Image is not in qcow2 format

Since in one remote script we have change the default format from raw to qcow2 we are stuck. We can't add any kind of image. Because if you choose raw, the image is still created in raw, but the XML definition is still using qcow2...

ex for one on our VM:
/var/lib/one/datastores/100/2844/disk.2.attach

<disk type=‘file’ device=‘disk’>
<driver name=‘qemu’ type=‘qcow2’ />
<source file=’/var/lib/one//datastores/100/2844/disk.2’ >
</source>
<target dev=‘vdb’/>
</disk>

As said, even if we choose raw, type stays on qcow2. We have the same problem on datastores with SSH and QCOW2 types.

This is a regression, this was working fine with OpenNebula 5.2.

- OpenNebula 5.2 upgraded to 5.4 => KO
- Fresh OpenNebula 5.4 => KO

https://forum.opennebula.org/t/cant-attach-disk-after-upgrade-to-5-4/4842

Screenshot from 2017-09-01 10-45-38.png - I've tested all posible options (47.9 KB) Abel Coronado, 09/01/2017 08:47 AM

Associated revisions

Revision aba4edfd
Added by Abel Coronado about 2 years ago

B #5336 Solved bug in attach volatile disk (raw, qcow2) (#437)

Revision d854cb3f
Added by Abel Coronado about 2 years ago

B #5336 Solved bug in attach volatile disk (raw, qcow2) (#437)

(cherry picked from commit aba4edfd4ef7f70000c5ab53e315b877f8868d55)

History

#1 Updated by Abel Coronado about 2 years ago

Hello Edouard,

You're right. There was a problem with vCenter hidden fields.
It's fixed.

Thanks for the report.

Best regards,
Abel.

#2 Updated by Abel Coronado about 2 years ago

  • Assignee set to Abel Coronado
  • Target version set to Release 5.4.1
  • % Done changed from 0 to 100

#3 Updated by Abel Coronado about 2 years ago

  • Category set to Sunstone

#4 Updated by Tino Vázquez about 2 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Also available in: Atom PDF