Bug #703

Unable to load vmm_ec2: MAD did not answer INIT command

Added by Patrice Lachance over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:06/29/2011
Priority:HighDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - Auth
Target version:Release 3.0
Resolution:fixed Pull request:
Affected Versions:

Description

Hi,

Unable to load the vmm_ec2 driver with the current master branch (pulled today).

Message in oned.log
-------------------
Wed Jun 29 12:29:25 2011 [VMM][I]: Loading Virtual Machine Manager drivers.
Wed Jun 29 12:29:25 2011 [VMM][I]: Loading driver: vmm_kvm (KVM)
Wed Jun 29 12:29:26 2011 [VMM][I]: Driver vmm_kvm loaded.
Wed Jun 29 12:29:26 2011 [VMM][I]: Loading driver: vmm_ec2 (XML)
Wed Jun 29 12:29:26 2011 [MAD][E]: MAD did not answer INIT command

From one_vmm_ec2.log
--------------------
/srv/cloud/one30/lib/ruby/OpenNebulaDriver.rb:114:in `join': can't convert Hash into String (TypeError)
from /srv/cloud/one30/lib/ruby/OpenNebulaDriver.rb:114:in `initialize'
from /srv/cloud/one30/lib/ruby/VirtualMachineDriver.rb:75:in `initialize'
from /srv/cloud/one30/lib/mads/one_vmm_ec2.rb:70:in `initialize'
from /srv/cloud/one30/lib/mads/one_vmm_ec2.rb:260:in `new'
from /srv/cloud/one30/lib/mads/one_vmm_ec2.rb:260
/srv/cloud/one30/lib/ruby/OpenNebulaDriver.rb:114:in `join': can't convert Hash into String (TypeError)
from /srv/cloud/one30/lib/ruby/OpenNebulaDriver.rb:114:in `initialize'
from /srv/cloud/one30/lib/ruby/VirtualMachineDriver.rb:75:in `initialize'
from /srv/cloud/one30/lib/mads/one_vmm_ec2.rb:70:in `initialize'
from /srv/cloud/one30/lib/mads/one_vmm_ec2.rb:260:in `new'
from /srv/cloud/one30/lib/mads/one_vmm_ec2.rb:260

Associated revisions

Revision 59291f95
Added by Javi Fontan over 9 years ago

bug #703: wrong driver initialization

History

#1 Updated by Javi Fontan over 9 years ago

There was a bug caused by the changes made to the driver libraries. Should be fixed with 59291f95.

#2 Updated by Javi Fontan over 9 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF