Bug #1027

oned can not find kvm on fedora (RHEL)

Added by Ilkka Tengvall over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:12/13/2011
Priority:NormalDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:-
Target version:-
Resolution:invalid Pull request:
Affected Versions:OpenNebula 3.2

Description

due kvm binary being /usr/bin/qemu-kvm on redhat distros:

Tue Dec 13 09:23:55 2011 [DiM][I]: New VM state is ACTIVE.
Tue Dec 13 09:23:55 2011 [LCM][I]: New VM state is PROLOG.
Tue Dec 13 09:23:55 2011 [VM][I]: Virtual Machine has no context
Tue Dec 13 09:24:12 2011 [TM][D]: tm_clone.sh: onebula.dynamic.nsn-net.net:/var/lib/one/images/ffd42ac9951a8f772372dfa47bf3a8cd onebula:/var/lib/one//2/images/disk.0
Tue Dec 13 09:24:12 2011 [TM][D]: tm_clone.sh: DST: /var/lib/one//2/images/disk.0
Tue Dec 13 09:24:12 2011 [TM][I]: tm_clone.sh: Creating directory /var/lib/one//2/images
Tue Dec 13 09:24:12 2011 [TM][I]: tm_clone.sh: Executed "mkdir -p /var/lib/one//2/images".
Tue Dec 13 09:24:12 2011 [TM][I]: tm_clone.sh: Executed "chmod a+w /var/lib/one//2/images".
Tue Dec 13 09:24:12 2011 [TM][I]: tm_clone.sh: Cloning /var/lib/one/images/ffd42ac9951a8f772372dfa47bf3a8cd
Tue Dec 13 09:24:12 2011 [TM][I]: tm_clone.sh: Executed "cp -r /var/lib/one/images/ffd42ac9951a8f772372dfa47bf3a8cd /var/lib/one//2/images/disk.0".
Tue Dec 13 09:24:12 2011 [TM][I]: tm_clone.sh: Executed "chmod a+rw /var/lib/one//2/images/disk.0".
Tue Dec 13 09:24:12 2011 [TM][I]: ExitCode: 0
Tue Dec 13 09:24:17 2011 [LCM][I]: New VM state is BOOT
Tue Dec 13 09:24:17 2011 [VMM][I]: Generating deployment file: /var/lib/one/2/deployment.0
Tue Dec 13 09:24:18 2011 [VMM][I]: Command execution fail: 'if [ -x "/var/tmp/one/vmm/kvm/deploy" ]; then /var/tmp/one/vmm/kvm/deploy /var/lib/one//2/images/deployment.0 onebula 2 onebula; else                              exit 42; fi'
Tue Dec 13 09:24:18 2011 [VMM][I]: error: Failed to create domain from /var/lib/one//2/images/deployment.0
Tue Dec 13 09:24:18 2011 [VMM][I]: error: Cannot find QEMU binary /usr/bin/kvm: No such file or directory
Tue Dec 13 09:24:18 2011 [VMM][E]: Could not create domain from /var/lib/one//2/images/deployment.0
Tue Dec 13 09:24:18 2011 [VMM][I]: ExitCode: 255
Tue Dec 13 09:24:18 2011 [VMM][E]: Error deploying virtual machine: Could not create domain from /var/lib/one//2/images/deployment.0
Tue Dec 13 09:24:18 2011 [DiM][I]: New VM state is FAILED

History

#1 Updated by Ruben S. Montero over 7 years ago

  • Status changed from New to Closed
  • Assignee set to Ruben S. Montero
  • Resolution set to invalid

Hi
You can easily change the path to the emulator in etc/vmm_exec/vmm_exec_kvm.conf


#EMULATOR = /usr/libexec/qemu-kvm

AFAIK That default should work for fedora. So simply uncomment it and re-start opennebula

Also available in: Atom PDF