Bug #1057

Distinguish between ssh failure and "Could not find information driver im_kvm"

Added by Steffen Neumann about 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:01/12/2012
Priority:NormalDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:-
Target version:Release 3.6
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 3.0

Description

Hi,

For several month we're running a medium sized HPC cluster
on top of ONE-3.0, OS ubuntu 10.10, KVM, im_shared.

I just repaired (several) error states of hosts. The underlying problem
was that the NFSv4 shared directory /srv/one lost the proper idmap
on several clients, resulting in ownership nobody:nogroup for the
/srv/one/.ssh/authorized_keys files, which in turn caused passwordless ssh
for oneadmin to fail.

The error "Could not find information driver im_kvm" in the logfiles
was quite misleading, so I'd like to propose that ONE should distinguish
between ssh failures and "real" failures.

Yours,
Steffen

History

#1 Updated by Ruben S. Montero almost 8 years ago

  • Tracker changed from Feature to Bug
  • Affected Versions OpenNebula 3.0 added

#2 Updated by Ruben S. Montero almost 8 years ago

  • Assignee set to Ruben S. Montero

#3 Updated by Ruben S. Montero almost 8 years ago

  • Target version set to Release 3.6

#4 Updated by Carlos Martín almost 8 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

I can't reproduce this problem, this is what I get in oned.log:

Wed Apr 11 15:30:28 2012 [InM][I]: Monitoring host localhost (0)
Wed Apr 11 15:30:28 2012 [InM][I]: Command execution fail: 'if [ -x "/var/tmp/one/im/run_probes" ]; then /var/tmp/one/im/run_probes kvm 0 localhost; else                              exit 42; fi'
Wed Apr 11 15:30:28 2012 [InM][I]: Permission denied, please try again.
Wed Apr 11 15:30:28 2012 [InM][I]: Permission denied, please try again.
Wed Apr 11 15:30:28 2012 [InM][I]: Permission denied (publickey,password).
Wed Apr 11 15:30:28 2012 [InM][I]: ExitCode: 255
Wed Apr 11 15:30:28 2012 [InM][E]: Error monitoring host 0 : MONITOR FAILURE 0 -

It also looks like that error message, "Could not find information driver", is only logged if the driver MAD is not found, before the monitoring action is triggered.

Also available in: Atom PDF