Bug #1065

Migration from shared-fs host to ssh-fs based is broken

Added by Tino Vázquez over 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:01/18/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Release 3.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.2

Description

This at least should be mention in the documentation

From Grzegorz Kocur , Host with different TM - migration

--

Host A - uses tm_ssh, id 1
Host B - uses tm_shared, id 2
VM running on host A

onevm migrate <vmid> 2
and I have error:

Sat Dec 24 04:42:26 2011 [VMM][D]: Message received: LOG I 1093 save: Executed "virsh --connect qemu:///system save one-1093 /var/lib/one//1093/images
/checkpoint".
Sat Dec 24 04:42:26 2011 [VMM][D]: Message received: LOG I 1093 ExitCode: 0
Sat Dec 24 04:42:26 2011 [VMM][D]: Message received: SAVE SUCCESS 1093 -
Sat Dec 24 04:42:27 2011 [TM][D]: Message received: LOG I 1093 tm_mv.sh: Will not move, source and destination are equal
Sat Dec 24 04:42:27 2011 [TM][D]: Message received: LOG I 1093 ExitCode: 0
Sat Dec 24 04:42:27 2011 [TM][D]: Message received: TRANSFER SUCCESS 1093 -
Sat Dec 24 04:42:27 2011 [VMM][D]: Message received: LOG I 1093 Command execution fail: 'if [ -x "/var/tmp/one/vmm/kvm/restore" ]; then /var/tmp/one/v
mm/kvm/restore /var/lib/one//1093/images/checkpoint phoenix 1093 phoenix; else exit 42; fi'
Sat Dec 24 04:42:27 2011 [VMM][D]: Message received: LOG E 1093 restore: Command "virsh --connect qemu:///system restore /var/lib/one//1093/images/che
ckpoint" failed.
Sat Dec 24 04:42:27 2011 [VMM][D]: Message received: LOG E 1093 restore: error: Failed to restore domain from /var/lib/one//1093/images/checkpoint
Sat Dec 24 04:42:27 2011 [VMM][D]: Message received: LOG I 1093 error: Failed to create file '/var/lib/one//1093/images/checkpoint': No such file or d
irectory
Sat Dec 24 04:42:27 2011 [VMM][D]: Message received: LOG E 1093 Could not restore from /var/lib/one//1093/images/checkpoint

IMO the problem is migration uses host B TM (shared), and doesn't scp disk image and checkpoint to host B.
Is it a bug? Any workaround?

History

#1 Updated by Ruben S. Montero over 9 years ago

  • Target version changed from Release 3.4 - S0 to Release 3.4

#2 Updated by Ruben S. Montero about 9 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

This should work now thanks to the Datastore functionality. Closing this one.

Also available in: Atom PDF