Bug #1074

Missing sched.conf after upgrading 3.0 -> 3.2 (from sources)

Added by Giovanni Toraldo about 8 years ago. Updated over 7 years ago.

Status:ClosedStart date:01/21/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Release 3.6
Resolution:wontfix Pull request:
Affected Versions:OpenNebula 3.2

Description

Hi,

I understand that when using install.sh -k the entire etc contents copying is skipped, but after trying to start back one after the upgrade I was getting:

$ one start

Error while parsing configuration file:
Error opening template file
Error reading configuration file.
Error trying to create default group: 
oned failed to start

Error messages are pretty uninformative, I've managed which component was raising them analyzing the start-up script and running each component by hand.

I've solved manually copying ./src/scheduler/etc/sched.conf in my $ONE_LOCATION/etc

Maybe it's sufficient to mention it in the upgrade notes, improving errors messages will be better, copying new configuration files that doesn't exists yet in install.sh may be the best.

Thanks.

History

#1 Updated by Giovanni Toraldo about 8 years ago

I noticed only now #914, it will solve this kind of problems as well.

#2 Updated by Ruben S. Montero over 7 years ago

  • Target version set to Release 3.6

#3 Updated by Ruben S. Montero over 7 years ago

  • Status changed from New to Closed
  • Resolution set to wontfix

Hi Giovani,

Thanks for reporting this, I think this should be not needed by now. We'll include new configuration files as part of the update process if needed for future versions.

Cheers

Ruben

Also available in: Atom PDF