Bug #1135

OpenNebulaNetwork.rb looking in the wrong path for brctl

Added by Jorge Espada about 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:02/17/2012
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:CLI
Target version:Release 3.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.2

Description

I'm running opennebula 3.2.1 on debian squeeze, and when I try to create a vm on a node (also debian) fails, I found that the problem is in /var/lib/one/remotes/vnm/OpenNebulaNetwork.rb, the symbol reference :

:brctl=>"sudo /sbin/brctl"

is pointing to the wrong path, should be :
:brctl=>"sudo /usr/sbin/brctl"
Also a symblink can fix this too (/sbin/brctl -> /usr/sbin/brctl)

Some system Info:
OS: Debian (6)
Kernel: 2.6.32-5-amd64
bridge-utils version: 1.4-5
ruby: 1.8


Related issues

Duplicated by Bug #1136: OpenNebulaNetwork.rb looking in the wrong path for brctl Closed 02/17/2012

History

#1 Updated by Ruben S. Montero about 8 years ago

  • Target version set to Release 3.4 - Beta

#2 Updated by Ruben S. Montero about 8 years ago

  • Target version changed from Release 3.4 - Beta to Release 3.4

#3 Updated by Jaime Melis almost 8 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

This is the intended behaviour. The paths to the executables are easily located and changed just to ease the adaptation to any distro the administrator might be running on the hosts.

Since this is not a problem of the distribution of the frontend, but the distribution of the hosts we're leaving it as is.

However we've updated the documentation to reflect where to find these commands and how to fix it:
http://opennebula.org/documentation:rel3.2:nm#fixing_default_paths

Thanks for reporting this.

Also available in: Atom PDF