Bug #1175

Failure when doing successive suspend (or stop)

Added by Nicolas AGIUS about 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:03/22/2012
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - Auth
Target version:Release 3.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.2

Description

Steps to reproduce this bug :

onetemplate instantiate 1    # Start VM #58
onevm suspend 58
onevm resume 58
onevm suspend 58

The last command fail with this messages :

LOG I 58 Command execution fail: /var/tmp/one/vmm/xen/save one-58 /var/lib/one//58/images/checkpoint xen0vburo01 58 xen0vburo01
LOG E 58 save: Command "sudo /usr/sbin/xm save one-58 /var/lib/one//58/images/checkpoint" failed.
LOG E 58 save: Error: Save file:/var/lib/one/58/images/checkpoint exist!
LOG E 58 Could not save one-58 to /var/lib/one//58/images/checkpoint
LOG I 58 ExitCode: 1
LOG I 58 Failed to execute virtualization driver operation: save.
SAVE FAILURE 58 Could not save one-58 to /var/lib/one//58/images/checkpoint

xensave-issue1175.patch Magnifier (496 Bytes) Nicolas AGIUS, 03/22/2012 01:41 PM

Associated revisions

Revision d5ef9462
Added by Javi Fontan about 9 years ago

bug #1175: move old checkpoint files before save action

Revision 7a422473
Added by Javi Fontan about 9 years ago

bug #1175: move old checkpoint files before save action
(cherry picked from commit d5ef946230c2ab411af0dd8e32955abdd7ccc0de)

History

#1 Updated by Nicolas AGIUS about 9 years ago

This bug appears with XEN driver (not tested with other hypervisors)

Removing the old checkpoint file before doing xm save seems to be fine.
This patch has been successfully tested with suspend and stop< commands.

#2 Updated by Ruben S. Montero about 9 years ago

  • Category set to Drivers - Auth
  • Status changed from New to Assigned
  • Assignee set to Javi Fontan
  • Target version set to Release 3.4 - Beta

Thanks for the feedback. Scheduling this for the next release

#3 Updated by Ruben S. Montero about 9 years ago

  • Target version changed from Release 3.4 - Beta to Release 3.4

#4 Updated by Javi Fontan about 9 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Also available in: Atom PDF