Feature #1240

Add LVM drivers adapted to the new datastore subsystem

Added by Jaime Melis almost 8 years ago. Updated over 7 years ago.

Status:ClosedStart date:04/18/2012
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:Drivers - Auth
Target version:Release 3.6
Resolution:fixed Pull request:

Description

The old LVM drivers have been deprecated. New drivers compatible with the new datastore subsystem should be implemented.

tm_lvmssh-issue1240.patch Magnifier (32.3 KB) Nicolas AGIUS, 04/20/2012 05:09 PM

Associated revisions

Revision 8379ac09
Added by Jaime Melis almost 8 years ago

Feature #1240: Add LVM drivers adapted to the new datastore subsystem

Revision 03fa67bf
Added by Jaime Melis over 7 years ago

Revert "Feature #1240: Add LVM drivers adapted to the new datastore subsystem"

This reverts commit 8379ac09aa56971f69e8f2986d6a61723ec23c43.

Conflicts:

src/datastore_mad/remotes/xpath.rb

Revision ec7c9106
Added by Jaime Melis over 7 years ago

Feature #1240: Add LVM drivers adapted to the new datastore subsystem
(cherry picked from commit 8379ac09aa56971f69e8f2986d6a61723ec23c43)

Conflicts:

src/datastore_mad/remotes/xpath.rb

Revision d8d81435
Added by Jaime Melis over 7 years ago

Feature #1240: Update install.sh for LVM drivers

Revision 662f79c4
Added by Jaime Melis over 7 years ago

Feature #1240: Enable lvm as a datastore driver in oned.conf

Revision 0f042568
Added by Jaime Melis over 7 years ago

Feature #1240: minor typo in lvm/mvds

Revision f6793ad0
Added by Jaime Melis over 7 years ago

feature #1240: fix bugs and typos in lvm drivers

History

#1 Updated by Nicolas AGIUS almost 8 years ago

Damn, you where faster than me !

I've rewrote and improved the old tm_lvm for the new datatore system.
It support raw, gzipped and tgz images file and is designed to work with the filesystem datastore.

Patch is for the one-3.4 branch.

#2 Updated by Ruben S. Montero over 7 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF