Bug #1359

install_gems should install specific versions of gems

Added by Javi Fontan almost 9 years ago. Updated almost 8 years ago.

Status:ClosedStart date:07/13/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Packaging
Target version:-
Resolution:wontfix Pull request:
Affected Versions:OpenNebula 3.6

Description

For version 3.6 the sinatra version installed should be > 1.3.0. There's a problem with the actual gem installation checking as it does not check the version installed, only that it is installed. If an old version is installed the gem wont be upgraded.

Alternatively gem packages could be created with fpm so the correct versions are always installed.

History

#1 Updated by Ruben S. Montero almost 9 years ago

  • Target version set to Release 3.8

#2 Updated by Ruben S. Montero over 8 years ago

  • Status changed from New to Assigned

#3 Updated by Ruben S. Montero over 8 years ago

  • Target version changed from Release 3.8 to Release 4.0

#4 Updated by Ruben S. Montero about 8 years ago

  • Target version changed from Release 4.0 to Release 4.2

#5 Updated by Ruben S. Montero almost 8 years ago

  • Status changed from Assigned to Closed
  • Assignee deleted (Javi Fontan)
  • Target version deleted (Release 4.2)
  • Resolution set to wontfix

Also available in: Atom PDF