Bug #1386

100% CPU use. Unresponsible Sunstone

Added by VIVOSS company almost 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:07/23/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Release 3.8
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 3.6

Description

We've upgraded from 3.2 to 3.6 and encountered the same problem as here: http://www.mail-archive.com//msg07121.html

Sunstone works for some time after reboot, and when we try to see virtual machine stats - it becomes unresponsible, some ruby process uses 100% cpu. After some time (5 mins) it starts responding, although extremely slow and still using 100% CPU. There is nothing useful in logs. CLI utils continue working completely ok, it's only sunstone problem.

Server with opennebula is completely standalone without any external time sync (is serves as master ntp server with no internet connection), so leap second bug is not the case.

History

#1 Updated by Daniel Molina almost 9 years ago

In this thread a user experienced the same problem and fixed it installing the nokogiri gem

http://lists.opennebula.org/pipermail/users-opennebula.org/2012-August/009852.html

Hope it helps

#2 Updated by Ruben S. Montero over 8 years ago

  • Target version set to Release 3.8

#3 Updated by Ruben S. Montero over 8 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

This seems to be the cause for other users. As this (installation of nokogiri) is part of the standard installation procedure, I am closing this one. We'll reopen it if needed.

Also available in: Atom PDF