Feature #1449

READONLY, CLONE and SAVE attributes need to be revisited

Added by Jaime Melis about 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:09/10/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:Release 4.0
Resolution:fixed Pull request:

Description

READONLY, CLONE and SAVE are automatically set depending on the image type and persistency. This need to be changed in order to overrride the default image parameters, i.e.:

DISK  = [ IMAGE_ID = <ID>, SAVE = NO, CLONE = NO, READONLY = YES ]

The above configuration can't be achieved currently.

Associated revisions

Revision d797d04a
Added by Ruben S. Montero almost 8 years ago

feature #1449: Adds the IMMUTABLE persistent_type. This means that a persistent image will not be cloned and will not be modified, thus READONLY = YES and SAVE = NO

History

#1 Updated by Ruben S. Montero about 8 years ago

  • Tracker changed from Bug to Feature
  • Target version changed from Release 3.8 to Release 4.0

#2 Updated by Jaime Melis about 8 years ago

  • Resolution set to duplicate

This ticket is a duplicate of http://dev.opennebula.org/issues/1395 which already provides a patch.

#3 Updated by Jaime Melis about 8 years ago

  • Status changed from New to Closed

#4 Updated by Jaime Melis about 8 years ago

  • Status changed from Closed to New
  • Resolution deleted (duplicate)

Disregard the previous message. This ticket isn't a duplicate.

#5 Updated by Ruben S. Montero almost 8 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

This is now implemented in master. I think it can be applied to the 3.8 branch as is (let me know if there is any problem). The new feature will let you:

  • Specify the PERSISTENT_TYPE in an image template. If an image has PERSISTENT_TYPE="IMMUTABLE" in its template it will be treated as a persistent image but as it will be immutable it has READONLY="YES" (exposed as ro by the hypervisor) and SAVE="NO" (no move back operations will be performed)
  • READONLY flag can be set per DISK or IMAGE.

To try the suggested scenario, just set the image persistent and set it to immutable.

Also available in: Atom PDF