Bug #1464

Incorrect Datastore Count

Added by K S over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:09/11/2012
Priority:NormalDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:Core & System
Target version:Release 3.8
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.6

Description

onecluster list shows incorrect number of datastores, this seemed to be triggered by adding a datastore and removing it.
When datastore has 1 datastore it's showing 3 in list view.

oneadmin@frontend:~$ onecluster list
ID NAME HOSTS VNETS DATASTORES
100 cluster01 2 0 3
101 cluster02 2 0 3
102 cluster03 2 0 3

oneadmin@frontend:~$ onecluster show 100
CLUSTER 100 INFORMATION
ID : 100
NAME : cluster01

CLUSTER TEMPLATE

HOSTS
0
1

VNETS

DATASTORES
100

Associated revisions

Revision ed4713a5
Added by Ruben S. Montero over 8 years ago

bug #1464: Fix element count in onecluster when there is just one element

Revision 9ffb37ea
Added by Ruben S. Montero over 8 years ago

bug #1464: Remove unused function

History

#1 Updated by Ruben S. Montero over 8 years ago

  • Target version set to Release 3.8

#2 Updated by Ruben S. Montero over 8 years ago

  • Description updated (diff)
  • Category set to Core & System
  • Status changed from New to Assigned
  • Assignee set to Ruben S. Montero

#3 Updated by Ruben S. Montero over 8 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

This error was because of an incorrect count of the datastore elements from the oned response, the internal datastore count is ok. Fixed for onecluser command in master.

Also available in: Atom PDF