Bug #1652

Bug while determining image size from the Marketplace

Added by SZTAKI LPDS over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:11/13/2012
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Drivers - Auth
Target version:Release 4.0
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.8

Description

Dear Developers,

The regexp in libfs.sh script fs_size should be more permissive in order to deal with "size": "[SIZE]", type string. We discovered this error with our freshly uploaded appliance: http://marketplace.c12g.com/appliance/50a2552a8fb81d07f1000003
The problem is that the "size" item is not the last element, so there is a trailing comma, while with other appliances, the size item is the last one, so the regexp does not match.
Please check and apply the attached patch.

libfs.patch Magnifier (773 Bytes) SZTAKI LPDS, 11/13/2012 02:55 PM

Associated revisions

Revision 6f05c353
Added by Ruben S. Montero over 7 years ago

bug #1652: Bug while determining image size from the Marketplace. Path from SZTAKI LPDS

History

#1 Updated by Ruben S. Montero over 7 years ago

  • Status changed from New to Closed
  • Target version set to Release 4.0
  • Resolution set to fixed

Applied to master. THANKS!!!!!!

Also available in: Atom PDF