Bug #1674

Votatile disk hotplugging: fix target name

Added by Laurent Grawet over 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:11/30/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:Release 4.0
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.8

Description

Hi,

I have a problem with Xen hypervisor. We are currently using partitions (xvda1, xvda2) and not disks (xvda, xvdb) as target names in vm templates. The problem is when we try to hotplug a volatile disk (so you cannot specify target name), OpenNebula tries to register xvda instead of xvda3 (or eventually xvdb) which fails, of course.

I seems ok if I define disk targets (xvda and xvdb). In this case, the hotplug code tries to register xvdc.

Cheers,

Laurent

History

#1 Updated by Ruben S. Montero about 8 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Hi,

Now you can add a target to the attached disk, both in sunstone and in the CLI. This should solve the issue, as OpenNebula auto-target assignment would not work with partitions.

Also available in: Atom PDF