Feature #1739

Improve monitorization

Added by Jaime Melis over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:01/25/2013
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - Auth
Target version:Release 4.0
Resolution:fixed Pull request:

Description

1 - Reuse the monitorization to return all the information about all the VMs in the host, instead of an independent monitorization action per VM.
2 - Separe MONITOR commands from the rest so they can be ran simultaneously

Associated revisions

Revision 447c668f
Added by Javi Fontan over 6 years ago

feature #1739: im values in new lines

Revision b04e4498
Added by Javi Fontan over 6 years ago

fetaure #1739: make poll xen/kvm return all vms in template format

Revision 9c347926
Added by Javi Fontan over 6 years ago

feature #1739: add vm poll scripts to xen and kvm im

Revision a8d87609
Added by Javi Fontan over 6 years ago

feature #1739: change im vmware to report vms info

Revision ad9898fa
Added by Javi Fontan over 6 years ago

feature #1739: change ganglia probes to get all vms info

Revision eb82280d
Added by Javi Fontan over 6 years ago

feature #1739: change ganglia probes to get all vms info

Revision 40b1fe0f
Added by Javi Fontan over 6 years ago

Revert "feature #1739: change ganglia probes to get all vms info"

Commit moved to branch feature-1739, eb82280d9290b640ef015ecba4b94b05d89cf607

This reverts commit ad9898fa36b3c69e9726aa9c61aa2d93d933207e.

Revision e8a3f17e
Added by Ruben S. Montero over 6 years ago

feature #1739: IM driver returns information encoded in base64

Revision 19f18aa3
Added by Ruben S. Montero over 6 years ago

feature #1739: EC2 information manager returns information encoded in base64

Revision c209c03e
Added by Ruben S. Montero over 6 years ago

feature #1739: Dummy driver returns host information in base64 encoding

Revision b8b3f643
Added by Ruben S. Montero over 6 years ago

feature #1739: Moved SSL functions to one_util namespace. oned decodes messages from information drivers

Revision 8782676e
Added by Carlos Martín over 6 years ago

Feature #1739: Minor code cleanup

Revision f5e7143e
Added by Carlos Martín over 6 years ago

Feature #1739: VectorAttribute::vector_value checks the value contents

Revision 4cdedd2b
Added by Carlos Martín over 6 years ago

Feature #1739: Refactor VMMDriver poll so it can be called from IMMDriver

Revision e665b0b6
Added by Carlos Martín over 6 years ago

Feature #1739: Fix individual VM Poll

Revision 1a9600a6
Added by Carlos Martín over 6 years ago

Feature #1739: Update vm last_poll when the operation ends, instead of when it is triggered

Revision 547505a9
Added by Carlos Martín over 6 years ago

Feature #1739: Do not set last_poll when a VM is deployed

Revision ead72d74
Added by Carlos Martín over 6 years ago

Feature #1739: Detect missing VMs from the Host poll info, and move them to 'unknown'

Revision ea40607e
Added by Carlos Martín over 6 years ago

Feature #1739: All VMs are set to unk if the host poll fails

Revision 89f2cdac
Added by Carlos Martín over 6 years ago

Feature #1739: When an individual VM poll fails, the VM is set to unk

Revision ad44a979
Added by Carlos Martín over 6 years ago

Feature #1739: Do not update poll info for VMs that should not be in the reported host

Revision d95d0bdd
Added by Carlos Martín over 6 years ago

Feature #1739: Drivers only return VM/ID when the VM name is exactly one-id

Revision aac7ca94
Added by Carlos Martín over 6 years ago

Feature #1739: Move the logic of what to do with a failed poll to VMMDriver

Revision 5ad0a55c
Added by Carlos Martín over 6 years ago

Feature #1739: Drivers inform that the VM_POLL info is included, making things easier for the core when 0 vms are found

Revision 2ee15e4b
Added by Carlos Martín over 6 years ago

Feature #1739: Monitor disabled hosts also

Revision 22caac41
Added by Carlos Martín over 6 years ago

Feature #1739: Improve host monitoring performance

We don't need to retrieve and parse each Host xml body column, we
already have the Hosts in the cache

Revision 49fd57f4
Added by Carlos Martín over 6 years ago

Feature #1739: Monitor disabled hosts only if they have running VMs

Revision ce565ac5
Added by Carlos Martín over 6 years ago

Feature #1739: Update doxygen file

Revision e37c4d16
Added by Carlos Martín over 6 years ago

Feature #1739: Add messages when extra VMs are detected

Revision 64376538
Added by Tino Vázquez over 6 years ago

feature #1739: Fix wrong host vmware polling when libvirt returns warnings

Revision 2ea76884
Added by Carlos Martín over 6 years ago

Feature #1739: fix VMMD log levels, and omit redundant monitoring info

Revision 6de35457
Added by Carlos Martín over 6 years ago

Feature #1739: Decode the host poll info string also in case of error

Revision 4b9d2a49
Added by Carlos Martín over 6 years ago

Feature #1739: Remove unused var

Revision bf5fd2eb
Added by Carlos Martín over 6 years ago

Feature #1739: Touch remotes location at start time to force the refresh

Revision 7e9d1b80
Added by Carlos Martín over 6 years ago

Feature #1739: Move the host last_poll_time filtering to the DB query

Revision d749af70
Added by Carlos Martín over 6 years ago

Feature #1739: Merge oned.conf Host & VM monitoring intervals

Revision c5f28d8a
Added by Carlos Martín over 6 years ago

Feature #1739: Change host monitoring timeout to 5 minutes

Revision fd1a2d16
Added by Carlos Martín over 6 years ago

Feature #1739: Skip VMM monitoring the first period

Revision fd73ebf9
Added by Carlos Martín over 6 years ago

Feature #1739: Clean Host error messages when the problem is solved

Revision 701f33ca
Added by Ruben S. Montero over 6 years ago

featue #1739: Move Host and VM update functions to each class.

Revision 064e99df
Added by Ruben S. Montero over 6 years ago

featue #1739: Minor modifications

Revision 69b4cfc0
Added by Carlos Martín over 6 years ago

Feature #1739: Minor changes (code style, error message readability)

Revision 2fba9a4c
Added by Carlos Martín over 6 years ago

Feature #1739: If the VM poll info can't be parsed, the VM is set to 'unknown'

Revision 0277e743
Added by Carlos Martín over 6 years ago

Feature #1739: Fix bug in VM monitoring parser

Revision 9cfa59d0
Added by Carlos Martín over 6 years ago

Feature #1739: Fix bug in VM monitoring parser
(cherry picked from commit 0277e7430a993b3c24e7496134566bf619f4142e)

History

#1 Updated by Javi Fontan over 6 years ago

  • Status changed from New to Assigned
  • Assignee changed from Jaime Melis to Javi Fontan

#2 Updated by Carlos Martín over 6 years ago

The hosts only have one type of template error message, monitorization, but the VMs can have different messages: attach failed, monitorization failed, etc.

As the code is now, if the VM has an operation message (e.g. could not attach disk), a successful monitorization will clear that message.

Maybe we could define two types of errors: the ones that inform of a failed operation, and the ones that can be resolved on their own and can be cleared (monitoring).

The failed operations could be stored in a vector attribute:

ERROR_MESSAGES = [ ERROR = "attach failed because...", ERROR = "shutdown failed because..." ]

#3 Updated by Ruben S. Montero over 6 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Also available in: Atom PDF