Bug #1765

make AppFlow work with legacy rack

Added by OpenNebula Systems Support Team about 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:02/11/2013
Priority:NormalDue date:
Assignee:Daniel Molina% Done:

100%

Category:OneFlow
Target version:Release 4.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.2

Description

Currently for old distributions where rack = 1.1.0 and sinatra = 1.0, there is a "stack level too deep" error because the "settings" variable is referenced used in a scope that doesn't work with old versions. This should be patched so it works with any rack version.

History

#1 Updated by Ruben S. Montero almost 8 years ago

  • Target version set to Release 4.2

#2 Updated by Ruben S. Montero almost 8 years ago

  • Target version changed from Release 4.2 to Release 4.4

#3 Updated by Daniel Molina almost 8 years ago

  • Status changed from New to Closed
  • Assignee set to Daniel Molina
  • Target version changed from Release 4.4 to Release 4.2
  • % Done changed from 0 to 100
  • Resolution set to fixed
  • Affected Versions OpenNebula 4.2 added

Also available in: Atom PDF