Bug #1776

Unable to import from the marketplace

Added by Gregory McLean almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:02/21/2013
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Sunstone
Target version:-
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 3.8

Description

Selecting an image, then import to the local infrastructure fails:
ned.log:Thu Feb 21 11:38:01 2013 [ImM][E]: cp: Command "/var/lib/one/remotes/datastore/fs/../downloader.sh --md5 e53408073c6ab9b917f2fb75b86f4160 /var/tmp/thin-body20130221-3166-1jei97y-0 /var/lib/one/datastores/100/64d9e6626debdd49bb9d06564287bef2" failed: Hash does not match

However...
$ md5sum /var/lib/one/datastores/100/64d9e6626debdd49bb9d06564287bef2
e53408073c6ab9b917f2fb75b86f4160 /var/lib/one/datastores/100/64d9e6626debdd49bb9d06564287bef2

Now call me crazy...
but
e53408073c6ab9b917f2fb75b86f4160 /var/tmp/thin-body20130221-3166-1jei97y-0
e53408073c6ab9b917f2fb75b86f4160 /var/lib/one/datastores/100/64d9e6626debdd49bb9d06564287bef2

looks like a match to me as far as the md5hash is concerned...

History

#1 Updated by Gregory McLean almost 7 years ago

Open ssl comes up with the same result..

openssl dgst -md5 /var/lib/one/datastores/100/64d9e6626debdd49bb9d06564287bef2
MD5= e53408073c6ab9b917f2fb75b86f4160

#2 Updated by Ruben S. Montero almost 7 years ago

  • Category set to Sunstone
  • Status changed from New to Closed
  • Resolution set to worksforme

We cannot reproduce this one...

Also available in: Atom PDF