Backlog #1782

Make OpenNebula compatible with bsd OS

Added by Javi Fontan about 8 years ago. Updated about 6 years ago.

Status:ClosedStart date:02/25/2013
Priority:NoneDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:-

Description

OpenNebula is currently only compatible with GNU based OS (mainly linux). Incompatibilities found:

  • install.sh uses extended options of getopt only available on GNU getopt command
  • stat scripts from datastores use GNU stat formatting to get file size

Associated revisions

Revision 44549091
Added by Javi Fontan about 8 years ago

feature #1782: do not use extended parameters in non gnu getopt

Revision 455d56f9
Added by Javi Fontan about 8 years ago

feature #1782: datastore stat compatible with both GNU and BSD stat

History

#1 Updated by Javi Fontan about 8 years ago

In MACOSX core does not compile with new IPv6 changes. This CFLAGS must be set to fix the problem:

export CFLAGS="-Ds6_addr32=__u6_addr.__u6_addr32" 

#2 Updated by Ruben S. Montero almost 8 years ago

  • Category set to Core & System

#3 Updated by Ruben S. Montero almost 8 years ago

  • Tracker changed from Feature to Request

#4 Updated by Ruben S. Montero almost 8 years ago

  • Priority changed from Normal to Low

#5 Updated by Ruben S. Montero almost 8 years ago

  • Tracker changed from Request to Backlog

#6 Updated by Ruben S. Montero almost 8 years ago

  • Status changed from New to Pending

#7 Updated by Ruben S. Montero over 7 years ago

  • Priority changed from Low to None

#8 Updated by Ruben S. Montero about 6 years ago

  • Status changed from Pending to Closed

Also available in: Atom PDF