Bug #1817

oned hang

Added by Marco Losa almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:03/19/2013
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.8

Description

Dear support,

we have installed OpenNebula 3.8 from the source on Linux Gentoo, after the one start we can execute the one's command (like "onevm -list" or similar) for 10 or 15 times, then we have execution expired. We have this result with mysql and sqlite.

oned.log (6.86 KB) Marco Losa, 03/20/2013 02:13 PM

sched.log (553 Bytes) Marco Losa, 03/20/2013 02:13 PM

History

#1 Updated by Ruben S. Montero almost 7 years ago

Could you attach the oned.log file? Any hint to reproduce this? Is the process still running? Any changes in the networking configuration (specially http proxy's)?

#2 Updated by Marco Losa almost 7 years ago

Thanks very much for the fast response, so the step to generate the error is:


oneadmin@~ $ one start
oneadmin@~ $ ps -eaf|grep one

oneadmin 25199 25135 0 14:49 pts/0 00:00:00 su - oneadmin
oneadmin 25200 25199 0 14:49 pts/0 00:00:00 -su
oneadmin 25207 1 0 14:49 pts/0 00:00:00 /usr/bin/oned -f
oneadmin 25208 1 0 14:49 pts/0 00:00:00 /usr/bin/mm_sched
oneadmin 25257 25207 1 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_vmm_exec.rb -t 15 -r 0 kvm
oneadmin 25267 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_im_exec.rb -r 0 -t 15 kvm
oneadmin 25273 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_tm.rb -t 15 -d dummy,lvm,shared,qcow2,ssh,vmfs,iscsi
oneadmin 25282 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_hm.rb
oneadmin 25292 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_datastore.rb -t 15 -d fs,vmware,vmfs,iscsi,lvm
oneadmin 25301 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_auth_mad.rb --authn ssh,x509,ldap,server_cipher,server_x509

oneadmin@~ $ onevm list
ID USER GROUP NAME STAT UCPU UMEM HOST TIME

We can do this from 10 times, then:

oneadmin@~ $ onevm list
execution expired

oneadmin@~ $ ps -eaf|grep one
oneadmin 25199 25135 0 14:49 pts/0 00:00:00 su - oneadmin
oneadmin 25200 25199 0 14:49 pts/0 00:00:00 -su
oneadmin 25207 1 0 14:49 pts/0 00:00:00 /usr/bin/oned -f
oneadmin 25257 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_vmm_exec.rb -t 15 -r 0 kvm
oneadmin 25267 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_im_exec.rb -r 0 -t 15 kvm
oneadmin 25273 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_tm.rb -t 15 -d dummy,lvm,shared,qcow2,ssh,vmfs,iscsi
oneadmin 25282 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_hm.rb
oneadmin 25292 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_datastore.rb -t 15 -d fs,vmware,vmfs,iscsi,lvm
oneadmin 25301 25207 0 14:50 pts/0 00:00:00 ruby /usr/lib/one/mads/one_auth_mad.rb --authn ssh,x509,ldap,server_cipher,server_x509
oneadmin 25309 25207 0 14:50 pts/0 00:00:00 [oned] <defunct>
oneadmin 25311 25207 0 14:50 pts/0 00:00:00 [oned] <defunct>
oneadmin 25313 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25315 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25317 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25319 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25321 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25323 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25325 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25327 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25330 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25332 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25334 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25336 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25338 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>
oneadmin 25340 25207 0 14:51 pts/0 00:00:00 [oned] <defunct>


In attach you can find the logs files.

regards
Marco

#3 Updated by Ruben S. Montero almost 7 years ago

Hi,

Every thing seems ok at the core level (i.e. threads keep working see those --MARK-- in log file, plus you didn't actually do anything), I think that the problem is in the xml-rpc libraries. Can you send the version and compilation options for the libxmlrpc-c, latest I've tested is 1.33.01-1.

We have not tested gentoo :(

#4 Updated by Marco Losa almost 7 years ago

Hi,

the test describe in the previous post has been done with this version:

-----------------------------------------------
dev-libs/xmlrpc-c
Available versions: 1.28.03-r1{tbz2} ~1.32.05 {{abyss +cgi +curl +cxx +libxml2 static-libs threads tools}}
Installed versions: 1.28.03-r1{tbz2}(15:27:19 03/19/13)(abyss cgi curl cxx libxml2 -static-libs -threads -tools)
Homepage: http://xmlrpc-c.sourceforge.net/
Description: A lightweigt RPC library based on XML and HTTP

xmlrpc-c-config --features --version
c++ abyss-server curl-client
1.28.3
-----------------------------------------------

Then we have installed the version 1.32.05 and rebuild opennebula but the problem is the same.

Regards
Marco

#5 Updated by Marco Losa almost 7 years ago

Dear Support,

did you have any feedback about this issue ? We are going to install OpenNebula on some servers that have Linux Gentoo, but before we want to know if Gentoo support OpenNebula.

Best Regards
Marco

#6 Updated by Ruben S. Montero almost 7 years ago

Hi Marco

Sorry for the delay,did not have any other clue for this and do not have a Gentoo system to debug it.

Ruben

#7 Updated by Marco Losa almost 7 years ago

Hi Ruben,

we have solved, the problem was:

----
When installing libxmlrpc you have to specify that it will be compiled with thread support:

  1. USE="threads" emerge xmlrpc-c
    ----

Regards

#8 Updated by Ruben S. Montero almost 7 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Great news!. I've added a gentoo platform notes in the documentation. If you want to add anything else helpful for Gentoo users, just drop me a line or add it to this issue. I'll update the official documentation. THANKS

http://opennebula.org/documentation:rel3.8:ignc?&#gentoo_platform_notes

Also available in: Atom PDF