Bug #2081

Error split in VMware Driver if space in VM name

Added by Pierre Libeau over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:05/24/2013
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Drivers - Monitor
Target version:-
Resolution:wontfix Pull request:
Affected Versions:OpenNebula 4.0

Description

My ESX host in OpenNebula is on error : Error parsing monitor information and oned.log :

poll: Error executing: virsh -c 'vpx://10.6.15.1/DATACENTER_LAB/CLUSTER_ESX_LAB/-/?no_verify=1' --readonly dominfo 'XXX'

This bug seems to be caused by the use of space characters in the VM name.

I have tried to modify the file "/var/lib/one/remotes/im/vmware.d/vmware.rb" to be able to handle VMs with space characters in their name :

def get_vm_names
    rc, data = do_action("virsh -c #{@uri} --readonly list --name")
    return [] if !rc
    data.gsub!(/^.*----$/m, '')   
    data.strip! if data    
    lines=data.split(/\n/)
    lines.map do |line|
        line.split(/\r+/).delete_if {|d| d.empty? }[0]
    end.compact
end

But this modification doesn't work

History

#1 Updated by Tino Vázquez over 7 years ago

  • Status changed from Pending to Closed

This is indeed the case with VMs with spaces in the name, and thus created outside OpenNebula. This will be solved with the new IM drivers (see #1977).

#2 Updated by Tino Vázquez over 7 years ago

  • % Done changed from 0 to 100
  • Resolution set to wontfix

Also available in: Atom PDF