Bug #2081

Error split in VMware Driver if space in VM name

Added by Pierre Libeau about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:05/24/2013
Priority:NormalDue date:
Assignee:-% Done:


Category:Drivers - Monitor
Target version:-
Resolution:wontfix Pull request:
Affected Versions:OpenNebula 4.0


My ESX host in OpenNebula is on error : Error parsing monitor information and oned.log :

poll: Error executing: virsh -c 'vpx://' --readonly dominfo 'XXX'

This bug seems to be caused by the use of space characters in the VM name.

I have tried to modify the file "/var/lib/one/remotes/im/vmware.d/vmware.rb" to be able to handle VMs with space characters in their name :

def get_vm_names
    rc, data = do_action("virsh -c #{@uri} --readonly list --name")
    return [] if !rc
    data.gsub!(/^.*----$/m, '')   
    data.strip! if data    
    lines.map do |line|
        line.split(/\r+/).delete_if {|d| d.empty? }[0]

But this modification doesn't work


#1 Updated by Tino Vázquez about 8 years ago

  • Status changed from Pending to Closed

This is indeed the case with VMs with spaces in the name, and thus created outside OpenNebula. This will be solved with the new IM drivers (see #1977).

#2 Updated by Tino Vázquez about 8 years ago

  • % Done changed from 0 to 100
  • Resolution set to wontfix

Also available in: Atom PDF