Bug #2367

OpenNebula Drivers - problem with an argument for PRE, POST and CLEAN scripts

Added by Tomas Pyszko over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:10/09/2013
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Drivers - Network
Target version:Release 4.6
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.2

Description

Hello,

thank you for OpenNebula, it is a great system. You are doing great job!

I am trying to deploy Virtual Router Appliance for my virtual network which contains 800+ VMs.

It fails with error: /var/tmp/one/vnm/ovswitch/pre: Argument list too long

It is because the base64 encoded argument for the "pre" script contains a list of all the MAC<->IP pairs. Therefore it is very big.

My template for the virtual router looks like:

...
PUBNET $NETWORK[TEMPLATE, NETWORK="external"]
PRIVNET $NETWORK[TEMPLATE, NETWORK="internal"]
...

ON version is 4.2

thx

Regards,
TomasP

Associated revisions

Revision ec85fa08
Added by Jaime Melis about 6 years ago

Bug #2367: Send to the driver only the VM template section it requires
(cherry picked from commit 7df2ec9a183fe0b64feeec4440160f8de47ef5df)

History

#1 Updated by Ruben S. Montero over 6 years ago

  • Category set to Drivers - Network
  • Status changed from Pending to New

#2 Updated by Ruben S. Montero over 6 years ago

  • Target version set to Release 4.6

Thanks for the feedback, scheduling this for 4.6 as it'd require some major changes

#3 Updated by Ruben S. Montero about 6 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Now in master for 4.6

Also available in: Atom PDF