Bug #2772

Previous migrators incompatible with ruby < 1.9

Added by Carlos Martín over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:03/07/2014
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:CLI
Target version:Release 4.6
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.4

Description

Some commits made in #2586 used a method chaining syntax only valid for ruby >= 1.9.

Associated revisions

Revision 246ace70
Added by Carlos Martín over 6 years ago

Bug #2772: Fix onedb syntax for ruby < 1.9

Revision 0ef77743
Added by Carlos Martín over 6 years ago

Bug #2772: Fix onedb syntax for ruby < 1.9
(cherry picked from commit 246ace7072ec36ce0dfe697b1d1a48f1544a60d1)

Conflicts:
src/onedb/import_slave.rb
src/onedb/shared/4.4.1_to_4.5.80.rb

Revision af48f996
Added by Ruben S. Montero over 5 years ago

feature #3654 #2772: Message for onedb

History

#1 Updated by Carlos Martín over 6 years ago

  • Status changed from New to Closed
  • Target version set to Release 4.6
  • Resolution set to fixed

Also available in: Atom PDF