Bug #3012

OpenNebula Database Issue

Added by Pasquale De Michele over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:06/28/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 4.4, OpenNebula 4.6

Description

Hi all.

I have had the following problem with OpenNebula 4.4 (it is possible that also the version 4.6 may be affected):

during the creation of a new virtual machine, the disk space is saturated.

Therefore, in the database has been added a new instance in the table "vm_pool" (supposing with oid=708) but, in the table "pool_control", the value "last_oid" (supposing 707) for the tuple with the field "tablename" equal to "vm_pool" has not been updated (to 708).

As a result, after freeing the disk space, it was not possible to instantiate a new virtual machine, because the value "last_oid" incremented by 1 (707+1=708) was equal to value of the filed "oid" (708) of the last virtual machine instantiate.

In order to solve this issue, I directly modified this value in the database.

Maybe it could be useful to make atomic the sequence of operations to manage the creation of a new virtual machine in the database.

History

#1 Updated by Ruben S. Montero over 5 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

Hi

Before restarting oned, this should be addressed by the fsck tool. Note that the problem here is that the state of OpenNebula cannot be saved, so either the service needs to be interrupted, or fsck de DB when the problem is solved. The later is the recommended procedure.

Also available in: Atom PDF