Bug #3341

oneuser quota and oneuser defaultquota are not robust

Added by Jaime Melis over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:11/13/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:CLI
Target version:-
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.10

Description

as they fail very frequently with the "Broken Pipe" message or with this message:

➜ ~ oneuser defaultquota
[UserQuotaUpdate] Negative limits or bad format in quota VM = [ VMS=2 ]

0001-Bug-3341-Fix-broken-pipe-in-the-CLI-for-updates.patch Magnifier (1.98 KB) Jaime Melis, 11/18/2014 05:49 PM

Associated revisions

Revision f40d69d0
Added by Jaime Melis over 6 years ago

Bug #3341: Temporary fix that fixes de broken pipe use but breaks the CLI SSL support for Ruby 1.8.7

Revision 1363fdac
Added by Jaime Melis over 6 years ago

Bug #3341: Temporary fix that fixes de broken pipe use but breaks the CLI SSL support for Ruby 1.8.7
(cherry picked from commit f40d69d0bdb22712b2b8b2f68fde235f68c2e725)

History

#1 Updated by Ruben S. Montero over 6 years ago

  • Target version set to Release 4.10.1

#2 Updated by Javi Fontan over 6 years ago

  • Assignee set to Jaime Melis

#3 Updated by Jaime Melis over 6 years ago

Has been temporarily fixed, but we have broken the CLI SSL support for Ruby 1.8.7.

A better patch is attached.

#4 Updated by Ruben S. Montero over 6 years ago

  • Target version changed from Release 4.12 to Release 4.10.2

#5 Updated by Ruben S. Montero over 6 years ago

  • Status changed from Assigned to New
  • Assignee deleted (Jaime Melis)
  • Target version deleted (Release 4.10.2)

#6 Updated by Ruben S. Montero about 6 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

This is fixed for Ruby > 1.8.7. As this is a very old version of Ruby we are not applying the patch. In this issue we'll leave it for users interested in applying it.

Also available in: Atom PDF